Article: SSO login issue with SmartAssist for Edge Browser

#Problem Statement#
Users Facing SSO Login issue with Smart Assist for Edge Browser.

#Root Cause#

Sometimes, this error occurs when the authentication method used during a previous login differs from the method you are currently attempting to use.

For example, if you previously logged into Microsoft using password authentication and have now enabled Multi-factor Authentication (MFA) and are trying to log in with MFA enabled, the issue arises.

The reason is that the previous login authentication context is associated only with password authentication, while the current login process expects a Multi-factor Authentication context.
This mismatch in authentication methods prevents a successful login which seems to be an issue only specific to Edge browser. There is no issue from other browsers. Even works in In-private tab of Edge.

#Workaround 1#
Suggest the users to clear “Local Storage” and “Session storage”

Steps: Once you are on Smartassist.kore.ai

  1. open Developer tools of the browser.
  2. Go to Application Tab.
  3. Go to Storage
  4. “Clear” storage for “Local Storage” and “Session storage”

The above steps should solve the problem ideally.
Reference Screenshot:

If the issue still persists, please suggest the users to follow the below workaround.

#Workaround 2#
Suggest the users to follow the below steps and retry again.

a) Try logging out of all your SSO sessions. That is, logout from Microsoft in your browser.

b) Proceed with clearing cookies specific to Microsoft. Or delete them by navigating to browser settings.

Reference Screenshot: