Web SDK Integration documentation is not proper

channel

(Varun KH) #1

Hi, I am trying to integrate the chatbot with Web/Mobile Channel using Web Bot SDK. The Documentation is misleading sometimes and hence we are not able to establish a connection over the channel. For Eg: We are asked to start the ngrok server in the 21st point of “Installing and Running the Kore.ai Web SDK” but there is we need more clarity with the same as to which port needs to be used to start the ngrok. Also in the 22nd point we are asked to start the app.js file, but in the latest code we donot find any such file in the “web-kore-sdk-master.zip” which has been downloaded from “https://github.com/Koredotcom/web-kore-sdk”. Request you to provide us clarity on this document and if possible also update the document with respect to the above mentioned issues.


(Subrahmanyam Donepudi) #2

@varun.kh Please ignore point 21 and follow the below steps to have your webapp running with the webSDK integrated in it.
21.Go to home directory
cd SDKApp
22.Install dependencies using following command
npm install
23.Download and then uncompress the Kore.ai Web SDK from https://github.com/Koredotcom/web-kore-sdk into the test application …/sdk folder of the SDKApp test application. The Web SDK contains the libraries used to communicate and run the bot in the test application using the Web/Mobile Client channel. You will need to configure settings in the index.html file for your computer.
24.Start SDKApp
node startServer.js
image
25.Access the application in any browser using the following link
http://localhost:3000

We have communicated the issue with instructions to the documentation team and will resolve it soon


Can we deploy Bot on to Office 365?
How to integrate with google hangouts
(APPS POPO) #3

hey guys i also want to know this Am facing the same problem. Hope anyone here can help me too. Thanks in advance.
regards


(swathi vadlamani) #4

Hi, welcome to Kore community. Can you please let us the issue you are having while integrating Kore web sdk?

Thanks
Swathi