Table API Connect


I know you’ve seen this alot. I’m trying to just connect to my table I’d created, and cannot.

I input into postman my URL:
auth as my JWT

Always get
“errors”: [
“msg”: “Invalid SDK credentials”,
“code”: 4002

Images included

In my previous experience, I got the same error when I use a different JWT… I may suggest to ensure you have the right JWT token to send the request, by doing a double-checking the payload and secret textfields in this page.

Thank you for the quick response! I did use the JWT token converter you’d sent, and included the applications “Client Secret” as the appId to produce my JWT token. Setup like so:

But still get that error.

You are using jti in the app. This would mean that your payload contains jti and has expiry less than an hour. It also usually means that you won’t be able to replay an api unless you are using a new token every time.
Please remove jti from the app. Save, and try.

Hey Swata,

Thank you again for the quick reply. I’ve removed the jti selection, refreshed the token and input the appId into the JWT converter:

Still receiving the “msg”: “Invalid SDK credentials”, “code”: 4002 error message.


While creating a JWT token you need to use the client ID as appId and not the secret. You will need to sign with the secret.

That worked, I was able to ping the API no problem. Thanks!