SDKApp error on running ate localhost


(Pedro Ferreira) #1

SDK App doesn`t run properly
Following the documentation tutorial: https://developer.kore.ai/docs/bots/sdks/kore-ai-web-sdk-tutorial/
Tried with node 6 / 10 / 12

Follows the error
Not Found
404
Error: Not Found
at xxxXLOCAL_MACHINE_PATH_xxx\SDKApp\app.js:32:13
at Layer.handle [as handle_request] (xxxXLOCAL_MACHINE_PATH_xxx\SDKApp\node_modules\express\lib\router\layer.js:95:5)
at trim_prefix (xxxXLOCAL_MACHINE_PATH_xxx\SDKApp\node_modules\express\lib\router\index.js:312:13)
at xxxXLOCAL_MACHINE_PATH_xxx\SDKApp\node_modules\express\lib\router\index.js:280:7
at Function.process_params (xxxXLOCAL_MACHINE_PATH_xxx\SDKApp\node_modules\express\lib\router\index.js:330:12)
at next (xxxXLOCAL_MACHINE_PATH_xxx\SDKApp\node_modules\express\lib\router\index.js:271:10)
at xxxXLOCAL_MACHINE_PATH_xxx\SDKApp\node_modules\express\lib\router\index.js:618:15
at next (xxxXLOCAL_MACHINE_PATH_xxx\SDKApp\node_modules\express\lib\router\index.js:256:14)
at Function.handle (xxxXLOCAL_MACHINE_PATH_xxx\SDKApp\node_modules\express\lib\router\index.js:176:3)
at router (xxxXLOCAL_MACHINE_PATH_xxx\SDKApp\node_modules\express\lib\router\index.js:46:12)

Please, help.


(Karthik Tadikonda) #2

Hi @pedro.ferreira,

I will get back to you on this by 14 April 2020


(Swagat) #3

@pedro.ferreira did you run npm install for SDKApp?
Please refer to Unable to integrate the chatbot with the client/Mobile Channel Please Help us once.


(Pedro Ferreira) #4

yes, and runned and checked all paths


(Pedro Ferreira) #5

I followed your steps and also… reached the same point


(Swagat) #6

Can you please let us know -

  1. Screenshot of your folder structure of SDKApp and WebSDK.
  2. JWT URL you have configured. Share screenshot of bot kore-config.js and kore-widgets-config.js
  3. How are you serving your index html page.
    Try this once to check you have done all steps… Getting started with widget sdk (v7.2 onwards)

(Pedro Ferreira) #7

web-kore-sdk branch: master

image
image
JWTUrl was replaced to something like you did, but i was using my ngrok domain provided: http://393d4817.ngrok.io

image (this section wasn`t in any point part of a tutorial)

image


(Swagat) #8

kore-widgets-config.js is only needed in case you are using widgets. You can skip that part.
I see that JWT URL is incorrect. If you are using JWT service from our SDKApp you will need to use
http://localhost:3000/api/users/sts
or http://393d4817.ngrok.io/api/users/sts (in case you have exposed the 3000 port through ngrok)

Also are you serving the index.html as http://localhost:3000/UI/index.html OR opening directly from the directory?


(Pedro Ferreira) #9

serving
The correct JWTUrl worked
but the bot isnt respondig with FAQs neither with task flow
image


(Pedro Ferreira) #10

And i am not being able to see the requests through network debugger tab in browser


(Pedro Ferreira) #11

on ngrok
image


(Swagat) #12

That is a different topic. I would suggest that you check your bot kit connectivity (in case you are using it).
Try using the bot without bot kit also.