Platform testing with WhatsApp channel through infobip

Hello, One of my partner prospects is facing the below issues while testing the platform:

Partner - I tried to test your platform with WhatsApp - unfortunately unsuccessfully. I followed the instructions below:

and tried it via Infobip (for GupShup you need a verified Facebook account which unfortunately Facebook doesn’t allow me to do and Karix doesn’t have a free trial option). I have done everything as in the instructions and also created a test bot at but unfortunately, it does not work. No matter what I enter at the number, your bot does not respond. I can’t find any good debugging output or further instructions on Infobip or on your site (your instructions seem to be out of date for Infobip).


Partner - On the one hand, this question has been asked before (but remained unanswered until now):

On the other hand, I can’t create a proper post because I don’t have any debug output. Therefore, I thought rather that one makes perhaps with an expert from your Dev-Team perhaps times a short Onboarding-Video Conference. How do you proceed with other possible leads and prospects?

Can you please help in resolving this issue?


The documentation has been updated.

Please observe Steps 4 and 5 in the screenshot below on the Keyword setup in Infobip, which we cannot find in infobip interface.

Hi Swagat,
I’m also facing the same issue with infobip integration even after following the updated document. This new documentation is clear than the old document but at the end of the config setup of infobip, they mentioned using keywords from Infobip.

Attesting the matter that is there in the documentation and a screenshot of it for your reference

Note: If you’re using the development sandbox on Infobip, once the channel is enabled and published, you will need to send messages in the format “[Keyword on infobip](User input) ” For example, “Kore Hi.”

Hello @anandaditya1997 ,

I believe you are observing this issue with infobip integration because of the below missing step in the doc is :

  • Go to the “Channels and numbers” tab-> Go to Numbers-> Double click on the configured number → You can see the Edit keywork console.

→ If you want you can add a new keyword or edit the existing keyword at the KEYWORD field

->Seletc the forwarding filed as forward to HTTP

->Add URL in URL field

->Select the “Non-forwarding” option as a user conversation.

→ Click on save the configuration.

Please find the reference screenshot.

Hope this will help you!!!