Keep session open with Alexa


(Máté Horváth) #1

Hello!

I would like to use my chatbot in a convenient conversation with Alexa. For now all message nodes sends 'shouldEndSession' = true by default, meaning the conversation will stop with Alexa. This means that for every stuff I want I have to say ‘Alexa, open [MySkillName]’ , say what I want, session ends, repeat. What I want to do is say ‘Alexa, open [MySkillName]’ once, say what I want, it answers, I ask something else, answers and when I say something along the line “Okay, I’m done, bye” the session ends.

Did anyone have similar issues or have an idea for this? I tried to use entity nodes to detect context/intent switching:

50

But this results in an error message on Alexa’s side.

Also using this entity node in Botbuilder redirects me to the new intent, but doesn’t parse it for intents. So if that intent needs a number, and I provide it in the sentence, it only detects the intent, but fails to detect the number entity and the bot just asks for it with the prompt message. But this is another issue.

So again, does anyone know how is it possible to keep an Alexa Session open to actually make the conversation feel like a conversation?

Thanks for your answers in advance.

Best Regards,
Máté


(Yoga Ramya Mendu) #2

Hi Máté,

We understand your requirement.
This is a limitation from Alexa end.
Whenever a dialog task is completed, you will need to invoke the bot with the invocation name only.

Even with the Hold & Resume settings, it will always go to the invoked dialog but not resume to the existing one.

Let us know if you need any further clarification on the above.

Regards,
Yoga Ramya,
Kore Support Team.