Jump to previous entity on some validation not working

chatbots

(Tabish Khan) #1

I am trying to jump to a previous entity on if condition.
i have added the connection for the same but it seems like that it is not going to that entity.
If i create new entity it works for the same.


Start over the flow, clearing the all entities
Start over the flow, clearing the all entities
(Subrahmanyam Donepudi) #2

Hi @tabish13khan , once the entity is traversed in the dialog flow, the value would stay in the context unless cleared and so the connection rule to route to the entity wouldn’t prompt you to enter value again as it gets picked from the context.

If you were to ask the user for the entity value again, please add a script node and delete the entity value present in it and then route to the entity node.

Below is an example to demonstrate the same. Here if the user input is 5, then we are deleting the entity value using script node and prompting him to enter the value again.

image

image

image

image


(Tabish Khan) #3

Is there a way i can delete all the entities at once

Thanks for your response.


(Subrahmanyam Donepudi) #4

Welcome @tabish13khan. If you want to delete all the entities, provide delete context.entities in the script node.


(Tabish Khan) #5

Thank you Subhrahmanyam it was very helpfull and worked well.


(Emer Gilmartin) #6

Hi

Same request here!

I’ve tried a script node with delete.context.entities as well as delete.context.EntityN for individual entities but they’re not being cleared?


(Subrahmanyam Donepudi) #7

This issue can be disregarded as the problem seemed to be with bot configuration as mentioned in an other topic.


archived #8