Disabled Interruption at all level but still getting interrupted

Hi, I don’t want my task to have interruption. I have disabled and set do not allow interruption.
But still when I run my task and when it reaches a digital form node and instead of opening the form, when I try to enter a utterance it prompts me with a standard response saying I found a task do you wish to run it ?

How can I fix this ? Is it not possible to completely disable interruption when a task is running and haven’t completed fully?

Hi Narayan,

Thank you for reaching out to Kore.ai Community
Could you please share the screenshot of the interruption settings made on the bot ?

Thank you,
Srujan Madderla
Kore.ai Community Team

Hi @srujan.madderla , thanks.
Please find the Snapshots below

  1. There are two tasks one Showform and the other RET
    I want the Showform task to continue even if other utterances are made.
    Below is the example where I first triggered the showform task and a form shows up. Then when I uttered another Intent the message shows up saying would you like to RUN “RET task”

Below are the interruption settings for each task

For Showform task

For RET Task