Digital form not opening in web/mobile client integrated using SDKAApp and web-kore-sdk

We have created an Digital form in botbuilder and implemented that form in one of the dialog task, Its working (opening) fine in botbuilder test chat widget,

but when we integrated to web channel, that form is not opening (tried clicking multiple times) at all, could you please help us to resolve this issue,
Please find below web chat widget image for your referenceimage

Hi @aadil.hussain,

We have tried to replicate the issue at our end.
We are able to work with the form as per the functionality.

The form is opening in the web SDK.

Kindly send us the screenshots of the Form node settings and also please delete the current node & add a new form node to verify the issue.

Yoga Ramya

Here is the screenshot of setting

Previously, I don’t had web/mobile client prompt message, I added now and published it again, but still it is not working in localhost server.

Could you please share your setting page of the form node, or let me know the step by step guide,

Thanks in advance!

Actually we have used “open inline form” option inside the form setting and that is causing an issue, when we changed the setting to “open full page popup form”, please see screenshot for the same,

can we use this as a “open inline form” option?

Aadil Hussain

Hi @aadil.hussain,

We observe that the option “Open inline form” is not working as expected in WebSDK.
We will communicate this to our engineering team and update you accordingly.

Yoga Ramya

hi @yogaramya.mendu, i hope you are doing well, i am wondering if the problem of the digital forms for the web sdk has been fixed, im implementing one and it only works as open a full page, even when i have selected the inline option

@liliana.chacon @aadil.hussain

I can see Digital forms working without any problem from WebSDK. I guess you are not serving your SDK but opening the index.html directly from the browser.

Please try serving the WebSDk. It worked fine for me. The below documentation on WebSDk and SDK app can help on the same:


Please ensure the change ( after you ‘selected the inline option’) is published before being tested in the web-sdk.
Also as @ajay.putti suggested, please serve the page instead of opening as a standalone web-page. You can use any tool (like Kore provided - mentioned in the link Ajay sent; OR any other simple python/ ruby/ apache) to serve the page on your localhost.

1 Like

Hello @ajay.putti and @swagata.sengupta
Thank you very much, the proposed solution worked.