Custom Language Detection API


(Marc von Reutern) #1

Hello,
we have an on-Prem installation and therefore can’t enable multiple language, since we cannot reach the Google Language Detection API.

The documentation mentiones the possibility to change the Google API to a custom build one in the Kore Config (https://developer.kore.ai/docs/bots/advanced-topics/building-multi-language-bots/switching-language-selection/)

Could you provide more details. Where can we find the Config on our server and how do we change the API?

Thank you


(Yoga Ramya Mendu) #2

Hi @marc.von_reutern,

Currently, the provision to change the language Detection API for on-Prem installations has not yet been rolled out.

You would be receiving it with the 7.0 version which is scheduled to be available in the second quarter of 2019.

Also, the language detection API’s supported by the platform are Google and Kore.
If Google API is restricted in your environment, you will need to change the “langDetectionMode” value to “Kore” in the config.json file(/var/www/KoreServer/config/KoreConfig.json) in the future version.

As of now, the bot will provide the language options to the user to choose from and continues the conversation in the selected language.

The information in the documentation will be corrected. We have communicated to the documentation team.

We regret the inconvenience caused.

Let us know if you need any further clarification on the above.

Regards,
Yoga Ramya.


(Marc von Reutern) #3

Hello Yoga Ramya,
Thank you for the quick answer. We found the specifications of the Google API call in a file in /data/www/KoreServer/config/configs/i18n.json
Couldn’t we just change this path?

At the moment, we do not have the option to enable multiple languages at all. Once a second language is selected, the bot breaks, because it tries to detect a language, but receives no response.

Regrads


(Yoga Ramya Mendu) #4

Hi @marc.von_reutern,

As mentioned in our previous response, the API cannot be changed in the current version that you are in.

However, multiple language conversations should be working as mentioned.

The bot will provide the language options to the user to choose from and continues the conversation in the selected language.”

Kindly let us know the following:

1- Were you able to “enable” languages from the Bot >> Settings >> Language management.
2- Then, in the chatbot, are you able to get a message from the bot with language options where the user can choose the language to communicate to the bot.

Also, let us know the version details of the on-premise at your end.

Regards,
Yoga Ramya.


(Marc von Reutern) #5

Hello,

our version is 6.3 on Prem. We enabled the new language, and changed the translatable Bot components by hand. We set language selection to “Lifetime”.

When we chat with the bot in the botbuilder, it tries to call the API, fails as discussed, and asks the user for the language. When we select the default language, everything is fine. When we switch the language with “cheat language” the bot is not responding anymore. It just drops every conversation in the second language.

Regards
Marc


(Yoga Ramya Mendu) #6

Hi @marc.von_reutern,

We apologize for the delay and regret the inconvenience caused.
We are checking this with our engineering team to understand further.

We will update you asap.

Regards,
Yoga Ramya.