Component Ids are invalid/published


(Felipe Marquardt) #1

Trying to delete nodes but I receive this message:
download


(Yoga Ramya Mendu) #2

Hi @felipe,

We are not able to replicate the issue at our end.
Kindly share your bot export zip through our support portal.

You will be able to access the support portal from https://developer.kore.ai/

Regards,
Yoga Ramya.


(Felipe Marquardt) #3

Hello
I was not able to delete the nodes inside the task.
I deleted the task and recreated. All working fine now.


(Yoga Ramya Mendu) #4

Hi @felipe,

Thank you for the update.
In case, if you face this issue again, please send us the bot export zip through support portal.

Regards,
Yoga Ramya.


(Henry Correia) #5

Hello @yogaramya.mendu
May I re-open this question? In my case, I am not able to delete/create any node within the task due to this same error:
image

Then, if I go to the Dialog Tasks -> Manage Components, the entity that I just tried to create is there:
image

In my case, I cannot delete the task because I have one main task which manages all nodes…
Already tried to export the task and import it again and, unfortunately, did not work.

Is there any workaround to solve this?
Thank you in advance.


(Yoga Ramya Mendu) #6

Hi @henry.correia,

We suspect that this error occurs due to export and import of a task in the same bot where the taskId’s and component Id’s gets duplicated.

We request you to follow the below steps:

1- Export the tasks from this bot.
2- Create a new bot.
3- Import the tasks in this new bot.

Now, verify the issue.

Kindly let us know if the issue is still persisting even after implementing the above.

Regards,
Yoga Ramya.


(Henry Correia) #7

Hello @yogaramya.mendu

Thank you for replying!

I have followed the steps provided and unfortunately did not work.

Exporting task:
image

Importing task in a mew Bot:
image

I have got the message when trying to import the task to a new bot:
image

I have tried also:

If I export the Bot and import it as a new one, it says that was imported successfully:
image

However, no tasks were imported:
image

Thanks for any help, however, I have already started to re-build the flow :slight_smile:


(Swagata Sengupta) #8

Hello @henry.correia, would you please create a ticket with support@kore.com describing the issue. We will try to get on a call early next week and try to resolve it for you.


(Henry Correia) #9

Hello @swagata.sengupta ,
Ticket created!
Thank you very much