Can't activate "Enable Runtime Response Translation", 'Update' button always greyed out

Hi there!

I am currently struggling with making my bot multilingual. I have added a microsoft key and added 3 new languages, and I have the same problem with each language. The languages are definitely added, and I can talk to the bot in German for example, however, when I click on the German language in the “Language Managment” settings, “Enable Runtime Response Translation” is not enabled. I can toggle it on or off, but I can never update it as it is greyed out.

This is what it looks like when opening it:

And this is what it looks like after I try to enable it:

As you can see the ‘Update’ button is still greyed out and I can not actually update the bot to activate the “Enable Runtime Response Translation”. Even if I try to toggle the “Enable User Input Translation” or change anything else in these settings, the ‘Update’ button is always greyed out. Does anyone have any ideas what I might be able to do do change this?

Thank you so much!

Hello Benjamin,

Welcome to Kore.ai Community.
We have reviewed the reported use case.

Could you please share the bot access with koresupport@kore.com and provide the workspace name and bot details here.

We will try to replicate the issue on your bot and update you accordingly.

Thank you,
Srujan Madderla
Kore.ai Community Team

Hi Srujan,

Thank you for your response and help!

I just shared the app with the support team. The workspace/app name is called HTS Ai, and it would be used for the hotel industry where both needing to communicate with the app in different languages and also send out translated tasks in a preferred language to, for example, the cleaning staff, to enhance clarity and reduce miscommunications.

Hope that was all you needed, and thank you for your help again!
Best regards,
Ben

Hi Srujan, is there any update on this? :slight_smile:

Hey again!

I hope you have had a nice summer so far! Do you know if there is any update to this? It still is not working as intended. It is now enabled, however, if I wanted to make a change, the button is still greyed out.

That said, even though it is enabled, the bot still does not reply in the German language for example. Why might this be?
The bot does detect that I typed in German, but it never gets the intent correct, no matter how non-sensical it is, it will always choose one of the intents even if it is not related at all. It also never replies in German.

Thanks for your help!

Hello Benjamin,

Will check and update you on this by today EOD.

Thank you,
Srujan Madderla
Kore.ai Community Team